8-Bit-Nirvana Startseite  
?FATAL 6502 BURNOUT ERROR IN 38680
[ Home | Index | Werbung | Forum | Flohmarkt | Gästebuch | Links | Info ]

8-Bit-Forum

"Re: Problem mit Floppy 1571" von Nicolas Welte
(11.12.2001, 14:00)

(Dieser Artikel wurde 1149 mal aufgerufen)

Bezugsnachricht: Re: Problem mit Floppy 1571 (Ralf1)
Antworten: Re: Problem mit Floppy 1571 (Ralf1)

[ Antwort schreiben | Übersicht | Thema ]

Ralf1 schrieb am 11.12.2001, 13:44:
> Wenn beim Einschalten der 1571 keine Disk eingelegt ist, bleibt der
> Motor dauernd an (jedenfalls war er nach über 5 Minuten noch an).
> Wenn beim Einschalten eine Disk eingelegt ist, geht der Motor nach ca.
> 1 Sekunde aus. Wenn ich dann versuche, etwas zu laden, bleibt der Motor auch aus und es kommt nur die obengenannte Meldung "searching ...".

Seltsames Verhalten. Dann würde mich noch interessieren, was den Unterschied macht, und wie das Laufwerk merkt, ob eine Disk eingelegt ist oder nicht. Denn ob keine Disk oder eine Disk mit offenem Schreibschutz drin ist, das sieht immer gleich aus. Oder ist der Schreibschutz zugeklebt?

> Auch bei LOAD "$",9 passiert dasselbe, es kommt also nicht der zu
> erwartende "Device not present error".

Okay, dann reagiert die Elektronik auf das ATN Signal des C64, aber das DOS arbeitet es nie ab, und deswegen bleibt der Bus blockiert.

> Wird es dann wohl eher am DOS-ROM oder an der CPU liegen ?

Schwer zu sagen, wenn es überhaupt daran liegt. Dass scheinbar irgendwas noch funktioniert (Motor an/aus) spricht nämlich gegen beides. Aber das DOS ROM ist wenigstens gesockelt und Du kannst es mal rausnehmen und neu einsetzen, um Kontaktschwierigkeiten entgegenzuwirken. Falls Du eine Epromkarte hast, die 27256 Eproms aufnimmt, kannst Du damit das ROM auslesen und schauen, ob es noch okay ist. Dann wird es schwierig. Erstmal würde ich mit einem Multimeter die beiden Versorgungsspannungen 5V und 12V prüfen, danach mit einem Logiktester die Resetleitung an der CPU, sowie die Chipselectleitungen am ROM und an den I/O Chips. Daran sieht man dann in etwas, ob die CPU ansatzweise das tut, was sie soll. Die IRQ Leitung mal beobachten schadet auch nicht. Das ganze geht zur Not auch mit einem Multimeter, aber das liefert dann nur Mittelwerte, also ist es eher H oder eher L, oder irgendwas dazwischen.

Wenn die ganzen Signale soweit gut aussehen, ist wohl doch ein Bustreiber defekt. Ist eh der häufigste Defekt an den ganzen Laufwerken. Das kann man auch testen, indem man den Schaltplan nimmt, und jeweils Eingang und Ausgang der Treiber mit dem Multimeter anschaut. Wenn es da Unstimmigkeiten gibt, liegt ein Defekt vor. Dabei sollte der C64 ausgesteckt sein, da der die Pegel auch beeinflusst.

Nicolas


Lesezeichen für diesen Beitrag: del.icio.us del.icio.us Bei Mister Wong speichern Mister Wong Seite bei LinkARENA speichern LinkARENA Digg it Digg Slashdot it Slashdot StumbleUpon StumbleUpon


Antwort schreiben

Hier kannst Du auf die angezeigte Nachricht antworten. Beachte bitte die folgenden Punkte:
  • Dieses Forum befasst sich ausschließlich mit 8-Bit-Computern und Videospielen, Artikel zu anderen Themen sind off-topic und unerwünscht (für Computer mit mehr als 8 Bit gibt es hier aber auch ein eigenes Forum). Wenn der Vorschreiber schon vom Thema abweicht und Du unbedingt antworten möchtest, dann schreibe ihm lieber per e-mail.
  • Schreibe bitte so, dass sich niemand beleidigt oder angegriffen fühlt, auch wenn der Vorschreiber sich bereits im Ton vergriffen haben sollte. Solche Sachen löst man eh besser privat per e-mail.
  • Im Eingabefeld wird der komplette Text zitiert. Kürze die Zitate bitte so weit wie möglich, damit unnötiger Ballast vermieden wird. Hinweise zu richtigem und falschem Quoting findest Du hier: learn.to/quote.
Name:
E-mail:
Betreff:
Antwort:
Klicke bitte das Feld links an, falls Du Antworten auf diese Nachricht auch per E-mail bekommen möchtest.


       

Achtung: "SPAMFALLE" heißt nicht ohne Grund so, keinesfalls benutzen!



Mozilla Sidebar Opera Sidebar RSS 0.91 Newsfeed RSS 2.0 Newsfeed Add to Google Add to MyYahoo Spam Poison
Mozilla Sidebar Opera Sidebar RSS 0.91 Feed RSS 2.0 Feed Add to Google My Yahoo! Spam Poison

[ Index | Werbung | Forum | Flohmarkt | Gästebuch | Links | Info | Impressum/Datenschutz | News | Credits | Webmasters | Seitenanfang ]